文章详情页
linux - 非root用户不可用的命令是怎么实现的
浏览:253日期:2024-06-13 14:59:01
问题描述

显然不允许
今天在看书的时候突然发现chmod的权限是755,但一般用户还是无法使用,这是为什么?原本以为权限是700或744,结果是755,疑问。。。google了一下没找到答案,求教
问题解答
回答1:简单地说 (用户是否可执行程序文件) 和 (进程是否可执行特定指令) 这两个权限是分开的。
你已经有前一种权限了,你看到的错误信息是因为自己开的进程没有后一种权限。
回答2:chmod的权限说明一般用户可以使用该命令,但/tmp的权限修改需要超级用户的权限
sudo chmod 777 /tmp # 一般不修改/tmp文件夹权限
相关文章:
1. node.js - npm安装模块时,在cmd上显示的是一条白线,白线前面是一天反斜线转圈圈,然后就出现npm ERR错误了,求帮助,谢谢2. vue.js - android环境下在vue中引入vux.js 报错。3. css - width设置为100%之后列表无法居中4. 无法为JSP编译类:无法解析类型java.util.Map $ Entry。从所需的.class文件间接引用它5. 用python3的smtplib库发邮件一直返回无法发送邮件提示,是什么原因?6. 人工智能 - python 机器学习 医疗数据 怎么学7. 第6行的$_GET[’F’]没有定义啊?求问一下是什么意思?8. javascript - 怎样优化网页打开速度呢?9. tp5.0|php8.0 在window系统上写定时任务,执行报错10. javascript - 一排三个框,各个框的间距是15px,距离外面的白框间距也是15px,这个css怎么写?
排行榜

网公网安备