centos7 - nginx配置access_log问题
问题描述
我想给nginx开启访问日志。百度了一下,主要是在nginx.conf中配置

这一段
# log_format main ’$remote_addr - $remote_user [$time_local] '$request' ’# ’$status $body_bytes_sent '$http_referer' ’# ’'$http_user_agent' '$http_x_forwarded_for'’;## access_log logs/access.log main;
默认都是加#注释掉的,我想开启,也就是这段都取消#注释了。然后重启nginx却重启不了,提示Job for nginx.service failed because the control process exited with error code. See 'systemctl status nginx.service' and 'journalctl -xe' for details.
把#加回去又没事了,什么原因啊,包括开头的错误日志
#error_log logs/error.log;#error_log logs/error.log notice;#error_log logs/error.log info;
也是把#去掉想生效,结果nginx就启动不了。`
问题解答
回答1:1.请使用 nginx -t 检查配置文件获取 查看具体得错误信息
日志这样处理
log_format main ’$remote_addr - $remote_user [$time_local] '$request' ’ ’$status $body_bytes_sent '$http_referer' ’ ’'$http_user_agent' '$http_x_forwarded_for'’; access_log logs/access.log main;
相关文章:
1. javascript - 图片请求失败怎么去掉左上角的小图标?2. mysql中datetime列如何做筛选?3. javascript - vue中input的blur影响了下拉的点击事件如何解决4. mysql - SQL添加记录的数据来源于同一个表5. angular.js使用$resource服务把数据存入mongodb的问题。6. javascript - chart.js如何修改某个指定bar的颜色7. mysql sql where id in(25,12,87) 结果集如何用按照 25 12 87排序?8. windows-7 - Win7中Vmware Workstatoin与Xampp中Apache服务器端口冲突?9. mysql - phpMyAdmin无法导入数据10. css - 这些字体是怎么弄的?

网公网安备